Jump to content

Welcome to NeocoreGames Community
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!

Game Freezes At The Very First "logo Screen", Or At The Start Menu When I Move The Cursor.

  • Please log in to reply
No replies to this topic




  • Members
  • 3 posts

This problem is happening at all the four NeocoreGames that I have: "The Incredible Adventures of Van Helsing I, II, And III", And "Deathtrap".


Bug behavior:

sometimes (about 50% of the times), when i try to start one of these games listed above the game freezes at the very first "logo screen". When it passes this first "logo screen" and reaches the start menu screen it freezes when i move the cursor. When it freezes at the start menu, i can  listen the game audio but can't click on nothing and all the animations stops. However, I can still move the cursor in both cases of freezing.


When i try to start one of these games from outside of the Steam, clicking at the ".exe" file at the paste  "C:\Program Files (x86)\Steam\steamapps\common..." the problem persists, but its easier to reach the start menu and passes the very first "logo screen".


Below are some superficial informations about my computer:

- GPU: GeForce GTX1060 6Gb

- Processor: Intel i7-6700 3.4Ghz Skylake

- MOBO: Gigabyte Z170X-Gaming 3

- RAM: 32Gb DDR4

- OS: Windows 10 Home edition

- Mouse: Corsair M95

- Keyboards: Corsair K70 RGB


Links to the DXDIAG posts at "system information" thread at this site. Have to brake into two parts because the site said that the post was too long:


Part I



Part II




List of things i have already done to try to fix the problem:

- Disable atntivirus

- Disable firewall

- Disable Steam overlay

- Disconect all usb ports except the mouse and keyboards

- Check the option "Disable display scaling on high DPI settings" as suggested at the discussion thread of the link below



Thanks for any help! If you need more information, please say!

  • 0

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© NeocoreGames Ltd. Trademarks belong to their respective owners. All rights reserved.